Cisco Nexus 6004 (5596) Configuration – Fabricpath and Spine
By Vince
Here is a quick template to setup a Cisco Nexus 6004 or 6001 (recently renamed to the 5600 series, so now the 5696). These are solid 40G switches that offer a ton of features. Fabricpath is used in this template for switch to switch communication. These are also setup as a “Spine” switch in a spine/leaf two tier design.
This code was created on 7.0.x NX-OS.
!!!MGMT port config
interface mgmt0
vrf member management
ip address x.x.x.x/24
vrf context management
ip route 0/0 x.x.x.x
!
install feature-set fabricpath
feature-set fabricpath
feature udld
feature privilege
feature tacacs+
!
errdisable recovery interval 30
errdisable recovery cause all
!
ntp server x.x.x.x prefer use-vrf management
ntp source-interface mgmt 0
!
!!ssh regenerate the key
hostname xxxxx
no feature ssh
no ssh key rsa
ssh key rsa 1024
feature ssh
!
!!misc
no ip source-route
ip domain-lookup
udld aggressive
ip tcp path-mtu-discovery
!
!Change the balance algorithm to what fits your network
port-channel load-balance ethernet source-dest-port XXXX
!
!!enable jumobframes
system jumbomtu 9216
policy-map type network-qos fcoe-jumno
class type network-qos class-fcoe
pause no-drop
mtu 2158
class type network-qos class-default
mtu 9216
system qos
service-policy type network-qos fcoe-jumbo
!
!!logging and snmp
no logging console
no logging monitor
snmp-server location XXXXX
snmp-server source-interface trap mgmt0
snmp-server source-interface inform mgmt0
!
!Enable the traps that you actually want to monitor
no snmp-server enable traps
snmp-server enable traps XXXX
!
snmp-server community CCCC group network-operator
snmp-server community CCCC use-acl AAAA
snmp-server host x.x.x.x version 2c CCCC
!
banner motd ^
**********************************************************************BANNER BANNER
**********************************************************************
^
!
!Enable fast fabric
fabric-mode 40g
!!Configure necessary vlans for fabricpath.
!They must exist on each switch in the fabric to be used.
!Not recommended to pre-configure all of them, might cause errors.
!
vlan X-XXXX
mode fabricpath
!
!configure all interfaces as fabricpath
int ex/x-x
switchport mode fabricpath
!
!!!!!!!!!!UNIQUE CONFIG per switch
!Use a switch id scheme for your devices, something like xx for vpc, xxx for spines, xxxx for leafs.
!Also have one spine be the root so there is no confusion.
!
!Spine switch 1
fabricpath switch-id xx1
fabricpath domain default
root-priority 100
!
!Spine switch 2
fabricpath switch-id xx2
fabricpath domain default
root-priority 200
!
!
!!!SAVE THIS and RELOAD to switch to 40G fabric mode
copy run start
reload
!
!
!VALIDATION commands:
show fabricpath route
show fabricpath isis hostname switch-id
show fabricpath isis interface br
show fabricpath isis vlan-range
show int brief