Cisco Nexus 56128 Configuration Template
By Vince
Here is a quick template to setup a Cisco Nexus 56128 or any other switch in the 5600 series. These are solid 40G switches that offer a ton of features. Fabricpath is used in this template for switch to switch communication. These are also setup as a “Leaf” switch in a spine/leaf two tier design. These are running Nexus 7.0.X code.
For reference here is the spine configuration: Spine template
You might also need to configure native fiber channel, so check out this post on unified ports: Unified Ports and FC
!!!MGMT port config
interface mgmt0
vrf member management
ip address x.x.x.x/24
vrf context management
ip route 0/0 x.x.x.x
!
line con
exec-timeout 15
line vty
exec-timeout 15
!
!
install feature-set fabricpath
feature-set fabricpath
feature interface-vlan
feature hsrp
feature udld
feature privilege
feature tacacs+
feature lacp
feature vpc
!
errdisable recovery interval 30
errdisable recovery cause all
!
ntp server x.x.x.x prefer use-vrf management
ntp source-interface mgmt 0
clock timezone GMT 0 0
hostname XXXXXXXXX
!!ssh - regenerate a new key
no feature ssh
no ssh key rsa
ssh key rsa 1024
feature ssh
!!misc
ip tacacs source-interface mgmt0
no ip source-route
ip domain-lookup
udld aggressive
ip tcp path-mtu-discovery
!change to your port channel algorithm
port-channel load-balance ethernet source-dest-port XXXXX
!
!!!enable jumobframes
system jumbomtu 9216
policy-map type network-qos fcoe-jumbo
class type network-qos class-fcoe
pause no-drop
mtu 2158
class type network-qos class-default
mtu 9216
system qos
service-policy type network-qos fcoe-jumbo
!
!!!logging and snmp
logging server x.x.x.x use-vrf management
no logging console
no logging monitor
snmp-server location XXXXX
snmp-server source-interface trap mgmt0
snmp-server source-interface inform mgmt0
!
no snmp-server enable traps
!only enable the traps that you need
snmp-server enable traps XXXXX
!
snmp-server community XXXXXX group network-operator
snmp-server community XXXXXX use-acl XXXXX
snmp-server user admin network-admin XXXXX
snmp-server host x.x.x.x version 2c XXXXXX
!
!
banner motd 8
*****************************************************************************************
8
!
!!Configure only needed vlans for fabricpath. Need to exist on each switch in the fabric and created manually.
vlan AAAA
mode fabricpath
!Configure the interfaces, front end ports are normal vlan access ports
int e1/1-48
switchport access vlan AAAA
!
!!All uplinks to spines are fabric mode
int e1/49-52
switchport mode fabricpath
!
!
!!!!!!!!!!UNIQUE CONFIG per switch
!CHANGE THIS so leafs are 100X for the switch ID, VPC id's are 1X
!
!!!Leaf switch 1, the management ports are used for keepalives in this config
!!!STP config - the fabric needs to be the root and setup a domain so it appears as one switch to the other ethernet side
spanning-tree pathcost method long
spanning-tree domain 1
spanning-tree vlan 1-4093 priority 0
spanning-tree pseudo-information
vlan 1-4093 root priority 0
fabricpath switch-id 1001
!
!!!SVI AND HSRP Configs if you want to use layer 3
interface VlanAAAA
no shutdown
ip address x.x.x.B/XX
mtu 9216
hsrp version 2
hsrp AAAA
preempt
priority 150
ip x.x.x.A
!
!!!Leaf switch 2
!!!STP config - the fabric needs to be the root and setup a domain so it appears as one switch to the other ethernet side
spanning-tree pathcost method long
spanning-tree domain 1
spanning-tree vlan 1-4093 priority 4096
spanning-tree pseudo-information
vlan 1-4093 root priority 4096
fabricpath switch-id 1002
!
!!!!SVI AND HSRP Configs
interface VlanAAAA
no shutdown
ip address x.x.x.C/XX
mtu 9216
hsrp version 2
hsrp AAAA
ip x.x.x.A
!
!!!SAVE THIS
copy run start
!
!
!
!!!!!!!!!VALIDATION with two spines above you on ports 1/49 and 1/50
56128! sh fabricpath route
!!!OUTPUT Omitted
1/101/0, number of next-hops: 1
via Eth1/50, [115/10], 0 day/s 00:27:33, isis_fabricpath-default
1/102/0, number of next-hops: 1
via Eth1/49, [115/10], 0 day/s 00:29:13, isis_fabricpath-default
This will get your fabric setup and able to run layer 3. In this architecture we want to have all the services on your leafs. The spines only switch packets between fabricpath nodes using the Switch-ID, so you shouldn’t need to setup layer 3 services on them.